Can I use Press Loft with an old web browser?

The Press Loft Tech Team endeavours to make the website as accessible as possible, but as we constantly update our systems with the latest technologies, it is not always feasible to stay compatible with older browser versions. Currently, you should see no compatibility issues when viewing the site on the following browsers:

  • All versions of Chrome
  • Firefox 10 and newer
  • Safari 4.0 and newer
  • IE9 and newer

To ensure that Press Loft runs smoothly for you, we’d always encourage you to regularly update your browser.

Did this answer your question?